Announcement

Collapse
No announcement yet.

BMC - Bug Reporting Thread

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • BMC - Bug Reporting Thread

    With the new update there are a significant number of changes to everything behind the scenes so I'm starting a new thread to more easily track new and old issues.


    For specific errors on your city. (missing items, buildings etc. tiles returning uncaptured) please make sure to include your NK username so we can look at your data.

    Important about Special Items
    If you have lost special items, you need to email [email protected] with your information so we can fix this up for you. Make sure you have refreshed the game and gone into each city before emailing.


    Need Info:


    Known Bugs: <--- Read this list before posting.

    Starting arrow in wrong place: http://i.imgur.com/y9z0Cu8.png

    The "Build 20 monkey buildings" quest was updated so will re-appear (easy to get around for most people)

    Two new quests for first city will not be possible for a few players. We will be putting in a check for this.

    Engineer's '9 Inch Nails' doesn't pop frozen bloons.




    Old thread
    “What is right is not always popular and what is popular is not always right.” ~Albert Einstein

    Kiwibot Documentation
    Discord Server
    Check out my forum skins

  • #2
    Username: EPICIII
    Well, I guess I have two bloon labs now. Have a look at the image.
    I just found the second one on a tile I hadn't captured (it had a chest) and I was able to move it all the way here. I left and came back, and not only was it still where I left it, but the chest tile become captured. I didn't get anything, and now I somehow have two labs. It's completely useless but I'll keep them both just for show.
    I have no idea how to replicate it. I think logs get saved for every account so maybe you can find something.
    Just a note, in the build tab it said "1 of 1" despite there being two. I guess it broke the game.
    After that I tried to go to my other city and it failed to load. So I think something definitely broke.
    After refreshing the page it said "2 of 1" so the game seems to have recounted. I also noticed uncompleted quests were "reset", meaning I got notifications for all of them again even though I already had them. Functionally there's no difference though.
    After that, nothing new.

    Also, I've lost a lot of progress multiple times due to my connection being too poor to properly save. Not NK's fault in any way, just wanted to say maybe they should have manual saving for bad networks so less data needs to go back and forth.

    Image: http://imgur.com/a07CusY (because I can't attach)

    Comment


    • #3
      The fog on the map can bug, And something like this will end up occurring.
      The black tiles are ones normally hidden by the fog of war.
      Want to see the Daily Challenges I've had accepted? View them here.
      A collection of avatar's, That may or may not be restricted due to a size limit.
      http://i.imgur.com/HGjF4OP.gif
      http://i.imgur.com/7n36NSp.gif
      http://i.imgur.com/HnvAQZK.gif
      http://i.imgur.com/3NbRv78.gif
      http://i.imgur.com/lkDdGMF.gif

      Comment


      • #4
        This has happened to me many times before. Sometimes it will go away when the page is refreshed.

        Comment


        • #5
          will NK make/fix login page
          it takes too long to log in

          Comment


          • #6
            you have a big screen Squideer
            there is plenty of room on each side of the fence with signs

            Comment


            • #7
              Monkey Village rank 2/7/12 MK doesn't work properly.

              While playing around in BTD5 sandbox, I noticed that the monkey village, ninja monkey, and bomb shooter have the same range.

              Now, ninja and village have MK ranks that increase range, but bomb doesn't. Village has a bigger increment per 5 ranks (4% as opposed to 2%). I currently have rank 12 ninja and rank 11 village. When playing a tile I preformed the same test as the sandbox one, noticing that the village still has the same range as the bomb tower, but the ninja monkey's range is increased. Village should have had the largest range of the three.

              Originally posted by EPICI
              Username: EPICIII
              Well, I guess I have two bloon labs now. Have a look at the image.
              I just found the second one on a tile I hadn't captured (it had a chest) and I was able to move it all the way here. I left and came back, and not only was it still where I left it, but the chest tile become captured. I didn't get anything, and now I somehow have two labs. It's completely useless but I'll keep them both just for show.
              I have no idea how to replicate it. I think logs get saved for every account so maybe you can find something.
              Just a note, in the build tab it said "1 of 1" despite there being two. I guess it broke the game.
              After that I tried to go to my other city and it failed to load. So I think something definitely broke.
              After refreshing the page it said "2 of 1" so the game seems to have recounted. I also noticed uncompleted quests were "reset", meaning I got notifications for all of them again even though I already had them. Functionally there's no difference though.
              After that, nothing new.

              Also, I've lost a lot of progress multiple times due to my connection being too poor to properly save. Not NK's fault in any way, just wanted to say maybe they should have manual saving for bad networks so less data needs to go back and forth.


              Fixed the image for you
              Can't you demolish one of those labs?
              Last edited by Junior Monkey; 15-06-16, 05:15 AM.
              Ratings, Accepted DCs, and Today's and Tomorrow's BMC events, My BTD5 Mods
              Cringe worthy blog quotes of the week:
              Originally posted by Bobby Alexander
              Originally posted by crazywhiteman418
              Friday the 13th, NK Day of the Dead

              Comment


              • #8
                I finished the beacon tile and then lost the connection when I tried to fight the boss. After refreshing I discovered this situation. Not sure what to do now since I cannot fight the boss.
                "A question that sometimes drives me hazy: am I or are the others crazy?" ~Albert Einstein

                Comment


                • #9
                  Click directly on the beacon itself rather than the tile it's on.

                  Comment


                  • #10
                    Thank you! I was able to redo the tile and fight the boss this time.
                    "A question that sometimes drives me hazy: am I or are the others crazy?" ~Albert Einstein

                    Comment


                    • #11


                      Not sure how to replicate this, but let me just say that whenever I capture a tile while the map is glitched like this, Flash crashes. Of course, the tile won't save.
                      90 accepted daily challenges.
                      BTD5 rank: 83 - BMC levels: 35 (1st city), 28 (2nd city) - AP: 20545 (Level 41) - A masterpiece of logic - Rating scale - Forum errors
                      Originally posted by Katy Perry
                      Yeah, they slither like a centipede

                      Comment


                      • #12
                        Looks like Milestone Rewards do not work right. I just went to round 100 and got no rewards.

                        Sadly, I cannot show this to you, since I always get this message: "You are not authorized to create or remove attachments."

                        Comment


                        • #13
                          Originally posted by LTSchorsch
                          Looks like Milestone Rewards do not work right. I just went to round 100 and got no rewards.
                          My rewards seem to work just fine (even the 100). Guess it's been fixed?

                          Edit: It still says "Build: 160505". Unless NK is hiding an update from us.
                          I'm gonna defend an attack with the monkey team towers then, see if that's been fixed.

                          Edit again: Nope, looks like that'll be another thing of the bucket list: Monkey Team rewards don't pay out on MvMs.Why do they pay out on Mobile, but not on Flash? :?
                          Last edited by Junior Monkey; 01-07-16, 06:10 AM.
                          Ratings, Accepted DCs, and Today's and Tomorrow's BMC events, My BTD5 Mods
                          Cringe worthy blog quotes of the week:
                          Originally posted by Bobby Alexander
                          Originally posted by crazywhiteman418
                          Friday the 13th, NK Day of the Dead

                          Comment


                          • #14
                            I have some strange things going on in BMC today. First, this popped up when some towers had finished building in my level 40 city and I had switched over to the 2nd city. http://prntscr.com/boqu7m This did not seem to affect anything though.

                            Then I looked at my level 40 city and my honor is gone. It's down to 0 and It had been just over 3000 earlier when I defended an attack. Now I need to defend another attack and I'm sure to get a lot of honor from that person since I'm at zero now. Erynnmyrll
                            "A question that sometimes drives me hazy: am I or are the others crazy?" ~Albert Einstein

                            Comment


                            • Aaron
                              Aaron commented
                              Editing a comment
                              We can add your honor back if you contact support. If your city 2 upgrades were different to city 1 upgrades I would suggest checking that (can sometimes be copied over). We can fix that too.

                          • #15
                            I have a really big problem, and it can be summarized here:
                            http://imgur.com/jJ0FLbh

                            All the data, including the username and issue, is on that picture. It's been like that for over a day, and it seems that nobody has the same issue.
                            (Also, either this is Day/Month time, or sorry for the long bump. This just needs fixing.)

                            Comment


                            • Aaron
                              Aaron commented
                              Editing a comment
                              Can you log out, restart your comp, then log back in and try again?
                          Working...
                          X